
U90 Ladder 6.6.36 Features          Document version: 17/9/17 

 

Supports new Jazz 
model JZ20-UN20 

Digital Inputs including one HSC, 2 Analog/Digital Inputs, 1 Analog Input, 1 
PT100/TC , 5 Relay Outputs, and 2 Transistor Outputs. 

Wide Ladder Nets Ladder nets are now wide, and reach completely across your PC screen - 
no empty areas. This gives you twice the editing space 

"Run as Admin" U90 Ladder and other software utilities are now set to "Run as Admin". 

 

 

U90 Ladder 6.6.28 Features      

 

.u90 Download Files  You can now create .u90 download files by selecting Project> Create 
Download File, and following the on-line instructions. 

 

 

U90 Ladder 6.6.17 Features          Document version: 25/1/16 

 

Supports new Jazz 
models JZ20-T20HS, 
and JZ20-R16HS 

 JZ20-T20HS 
6 Digital, 2 Analog/Digital, 2 Analog, 3 High-speed Inputs, 8 Transistor, 5 
High-speed Outputs 
This model supports PWM via hardware configuration, no Special 
Functions required. 
 

 JZ20-R16HS 
6 Digital, 2 Analog/Digital, 2 Analog, 3 High-speed Inputs (HSC/Shaft-
encoder), 6 Relay Outputs 
 
These models both support Ethernet Add-on module for Jazz 2, enabling 
both MODBUS/TCP and PC-PLC communications. 

 

 

U90 Ladder 6.6.0 Features      

 

Supports new Jazz 
models JZ20-T10, and 
JZ20-T18  
 

 JZ20-T10 
6 Digital Inputs, 4 Transistor Outputs 

 JZ20-T18     
6 Digital, 2 Analog/Digital, 2 Analog Inputs, 8 Transistor Outputs 



Jazz20: 1 mSec 
Interrupt 

Jazz20 models now support an Interrupt of 1 mSec, via SB 96. 

 

 

U90 Ladder 6.5.0  

 

Supports new Jazz 
models JZ20-R10, R16, 
and R31 

Block PC Access (Jazz20 ONLY) 
Enables you to lock the communication channel and require a password to 
open it. 

 

 

@@@@@@@@ 

 

 

U90 Ladder 6.3.0 Features      

 

Supports new Jazz 
models JZ20-R10, R16, 
and R31 

These models: 
-Are 30x faster than JZ10 models 
-Comprise integral USB programming ports. 

 

U90 Ladder 6.1.0a Features          Document version: 12/3/09 

 

New I/O Expansion 
Modules   

Now supported by U90 Ladder: XL series I/O modules, offering more I/Os in 
less space. EX modules offer a built-in adapter, replacing the need for an 
EX-A1 adapter. Supported modules: 

 EX-D16A3-RO8 

 EX-D16A3-TO16 

 IO-D16A3-RO16 

 IO-D16A3-TO16 

Jazz Models Now supported by U90 Ladder  

 JZ10-11-UN20 

 JZ10-11-UA24 

Cold Start SI To cause PLC restart: 

 With initialization, set  SI 140 to -32500  

 Without initialization, set  SI 140 to-32000. 

Slovakian support 
 

To change the U90 Ladder interface language, select View>Language and 
click on the desired language. 



Updated help files  

Enfora GSM modem Better support for Enfora GSM modem in U90Ladder and OS 

 

 

 

U90 Ladder 5.2.6 Features      

 

Supports new Jazz 
model JZ10-11-PT15 

New model has 3 Digital, 3 Digital/Analog, 3 PT1000/NI1000 Inputs, 5 
Relay,1 pnp/npn Outputs. 

 

 

U90 Ladder 5.2.4 Features      

 

Download via RS485 
network 

Specify a single controller or range of controllers at download. 

 

U90 Ladder 5.2.3 Features          Document version: 16/08/07 

 

Telestar GSM modem  Now supported by U90 Ladder. 

Jazz: Keypad Entry The number of Keypad Entry Variables that include Set Limits has been 
increased to 16—Jazz only. 

Jazz: List variables The memory capacity for variables has been increased to 3K—Jazz only. 

 

U90 Ladder 5.10 Features          Document version: 14/03/06 

 

IO Expansion Module IO-PT400, IO-PT4K  
Two new modules offer 4 PT inputs (alpha): I/O-PT400 supports PT100 & 
NI100; I/O-PT4K supports PT1000 & NI1000 

New modem support 
Now supports Siemens TC65 modem 

Entering Information 
mode control 

The time that the <i> key must be held to enter Information Mode can be 
modified (3-20 seconds) via SI 178.  
Entering 0 disables Information mode. 



Information Mode SB 
54  

SB54 is ON when the <i> key is pressed, even when data is being entered 
into a Keypad entry Variable, and even if Information mode is disabled via 
SI 178=0 

MODBUS Improved performance at baud rates slower than 4800 

 

 

U90 Ladder 5.09      Document version: 18/01/07 

 

PID –Improved Algorithm 
(M91 only) 

SB 109 switches between the old and new improved algorithm. 

PID - Internal Auto-tune 
(M91 only)  

M91 controllers using OS V3.72 (B08) or later now feature PID Internal 
Auto-tune via SBs. Requires SB 109 ON. 

 

U90 Ladder 5.09      Document version: 20/08/06 

 

M90 PID Internal 
Auto-tune 

M91 controllers may now be easily tuned via SBs. Each PID loop is linked to two 
SBs, one to activate auto-tune, and one that signals when the process is 
complete. Check the new sample application: Help> Sample U90 Projects>PID 
M91 Auto-tune.U90. 

 

U90 Ladder 5.07      Document version: 20/08/06 

 

  

• New translation files for Polish and Hungarian 

• New hardware model M91-2-RA22 

• New hardware expansion unit I/O PT4X 

  

 

U90 Ladder 5.06 Document version: 24/07/06 

 

New Controller 
models 

Now supported in Hardware Configuration. 
 
JZ10-11-R31 
16 Digital, 2 Analog/Digital, 2 Analog Inputs, 11 Relay Outputs. 
 
JZ10-11-T40 



16 Digital, 2 Analog/Digital, 2 Analog Inputs, 20 Transistor Outputs. 
 
M91-2-RA22 
12 digital inputs, including high-speed counter/shaft encoder inputs,  
2 analog inputs, 2 temperature measurement inputs, I/O expansion and 
RS232/485 ports.  

Jazz Cloner 
support 

In Jazz OPLCs, Information Mode now supports the Jazz Program Cloner. Full 
details are in the Jazz User Guide. 

  

 

U90 Ladder 5.05 Document version: 08/06/06 

 

Certain minor issues relating to support for the new Jazz series were fixed in the new version 

  

 

U90 Ladder 5.00 Document version: 19/03/06 

 

New 
Controller 
models 

Jazz™ OPLC™ 
A new OPLC series that is now supported in Hardware Configuration. 
 
M92-1-R34 
This new M91 model runs off 24VDC, and offers 22pnp/npn digital inputs, including 3 
high-speed counter/shaft encoder inputs, 2 analog inputs, 12 relay outputs, I/O 
expansion and RS232/485 ports.  

New Features Drum 
The Drum Sequencer utility simulates a mechanical drum sequencer. Drum 
instructions are best suited for repetitive processes that consist of a finite number of 
steps.  
 
Immediate Outputs 
The M91-2-T38 now supports Immediate Set/Reset for outputs O 0, O 1, O 10, O 12, 
O 13, O 14, and O 15. 



New I/O 
module 
support 

IO-DI8ACH 
New I/O expansion module, offers eight 110/220VAC inputs 

Display 
Languages 

If your PLC model is 'multilingual' you can type and display a number of languages 
on the controller's LCD. When you install U90 Ladder, the Display Settings box 
opens, enabling you to determine a default language for the HMI Displays. After 
installation, you can change the PLC Display Language at any time. 

Modems Modem Services, on the Controller menu, replaces PC Modem Configuration. 
Modem Services enable you to initialize supported modems for both PC and PLC-
side modems, via a 'Prepare Modem' procedure. 

Database Read/Write 1024 integers from U90 Ladder. 

General 
Features 

8 Watch folders enable you to monitor groups of operands. 
Find & Replace now searches through Variables, Hardware Configuration, PID and 
SMS Configurations. 
New Utility: Find Text in Comment. 
Summary: Operands Not Referenced in Project. 

  

 

U90 Ladder 
4.01 

Document version: 05/12/05 

Bulgarian is now available from the View>Language menu. 

 
 

U90 Ladder 
4.00 

Document version: 22/ 11/ 05 



U90 Ladder 
Hardware 
Configuration 

M91-2-R34 
Runs off 24VDC, offers 22pnp/npn digital inputs, including 3 high-speed 
counter/shaft encoder inputs, 2 analog inputs, 12 relay outputs, I/O expansion 
and RS232/485 ports. 
 
IO-DI8ACH (soon to be released)  

Display 
Languages 

If your PLC model is 'multilingual' you can type and display supported languages, 
according to the selected default language. When you install U90 Ladder, the 
Display Settings box opens, enabling you to determine a default language for the 
HMI Displays. After installation, you can change the default language at any time. 

Modems Modem Services, on the Controller menu, replaces PC Modem Configuration. 
Modem Services enable you to initialize supported modems for both PC and 
PLC-side modems, via a 'Prepare Modem' procedure. 
PLC Phone Book now supports the '+' (plus) sign as well as the ',' (comma) 
symbol. 

Database Read/Write 1000 integers from U90 Ladder. 

Ladder: New 
Features 

• Import/Export Nets 
• Bookmarks 
• Import/Export Operand Descriptions 
• Rise/Fall Summary 
• Delete All Comments 
• Get Next Unused Operand when addressing elements 

General Features • Find & Replace now searches through Variables, Hardware Configuration,   PID 
and SMS Configurations. 
• New Utility: Find Text in Comment. 
  Summary: Operands Not Referenced in Project. 

 
 

U90 Ladder 
V3.81 

Document version: 22/ 06/ 04 

PID Server:  
Auto-tune PID 
loops 

The PID Server PC utility enables you to auto-tune PID loops for both the Vision 
and M90/91 controller series. Although it is installed as part of the VisiLogic/U90 
Setup, PID Server runs independently of other Unitronics software.  
PID Server tunes a PID loop by temporarily disabling the PLC's PID function, and 



tuning the loop while the PC controls the PID output. The new utility is located on 
the Tools menu in both VisiLogic and U90Ladder 

 
 

MODBUS 
New M91 feature 

MODBUS enables you to establish master-slave communications with any 
connected device that supports the MODBUS protocol, including SCADA 
systems. Any controller in the network may function as either master or slave 
using any of the controller's existing COM Ports. Unitronics currently supports 
RTU (binary) transmission mode.  

PID Function 
Last received  

The PID function has been modified: 
Negative Slope control has been added. 
The Deadband parameter has been removed. 
Please note that, in existing applications, the changes may require you to modify 
the P, I, and D parameters. 

SMS number 
New SIs, 188 to 192, now store the number of the last SMS received by the 
controller. 

  

U90 Ladder V3.65 Document version: 16/ 02/ 04 

 
 

O/S 360 B3 

  

U90 Ladder V3.64 Document version: 18/ 01/ 04  

 
 

Downloading 
Values to  
the M90 
Database 

Download values to the M90 Database, by defining regions of integers in the 
database, entering values, and downloading. Note that you can also copy and 
paste values to from other applications, such as Excel. 
These values can also be included in a .d90 download file. 

Timer resolution 
display 

A Timer Resolution field has been added in the Timer Preset window; note that 
this field is read- only. The resolution is a function of the Timer Preset Value. 



  

U90 Ladder V3.63  

 
 

Bug fix- 
Variables  

51- 64 could not be assigned descriptions. 

  

U90 Ladder V3.62  

 
 

Fast Outputs 
support 

M91- 2- TC2 

Display Fix  In the HMI Editor, some of the Jump conditions could not be viewed at a 
resolution of 600x800 (2- line models only); this has been fixed. 

 

  

U90 Ladder V3.61  

 
 

Supports new 
M91 model 

Supports M91- 2- R6C (2- line text display) 

    

U90 Ladder 3.60 Version changes  

 
 



Support for 2- 
line 
M91 model 

Supports M91- 2- T38, the first 2- line text display model. In addition to more 
text, up to 8 variables can be displayed on the LCD. When this model is 
selected, the HMI editor will show the larger display screen. Additional 
features include 36k memory, 64 HMI variables. 

New controller 
support 

M91- 19- 4TC2 

New I/ O module 
support 

IO- ATC8, 8 Thermocouple / Analog inputs 

New Special 
Functions 

Indirect GSM PIN Code and Calculating 'long' integers (M91 only) 

New System 
Operands 

SB 35- 38 Keypad entry completed, support the 4 additional variables that 
may be show on the LCD of 2- line display models. 
SI 187, Number of SMS messages to be deleted, enables you to delete up 
to 30 SMS messages. 

Undo Added to U90Ladder features 

  

 


